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12.2.4 Optional Lab: Customize Settings in Windows 7 
 
Introduction 
 
Print and complete this lab. 
 
This lab is comprised of five parts. This lab is designed to be completed in multiple lab sessions. 
 
Part 1: Managing Virtual Memory, Startup Options, and Windows Update in 
Windows 7 
 
In this part of the lab, you will customize Virtual Memory settings. You will customize the Startup 
Folder and RunOnce Key in the Registry. You will change the default Windows Update option. 
 
Recommended Equipment 

• A computer running Windows 7 
• Internet access 

 
 
Step 1 

Log on to Windows as an Administrator. 
 
Click Start > Computer.  
 
The “Computer” window appears. 
 

 
 

Step 2 
Double-click the Local Disk (E:) drive. 
 
Click Format disk to confirm the drive E: is to be formatted. 
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Step 3 
The “Format Local Disk (E:)” window appears. 
 
Select NTFS in the File system drop-down menu. 
 
Click Start. 
 

 
 
A “Warning” window appears. 
 
Click OK. 
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Windows formats the drive. 
 
When the “Format Complete” message appears, click OK. 
 

 
 
The “Format Local Disk (E:)” window re-appears.   
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Click Close. 
 

 
 
Close all open windows. 
 

Step 4 
Click Start > Control Panel > System and Security > System > Advanced system 
settings. 
 

 
 
The “System Properties” window appears. 
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Select the Advanced tab and then click Settings in the “Performance” area. 
 

 
 

Step 5 
The “Performance Options” window appears. 
 
Click the Advanced tab. 
 

 
 
What is the current size of the Virtual Memory (paging file)? 
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Click Change in the “Virtual memory” area. 
 

 
 
The “Virtual Memory” window appears. 
 
Remove the check mark from Automatically manage paging file size for all drives. 
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What Drive or [Volume Label] contains the paging file? 
 
 
 
 
Choose the E: drive. 
 
Click the Custom size radio button. 
 

 
 
Look at the recommended size in the “Total paging file size for all drives” section of the 
“Virtual Memory” window. 
 
Type in a number smaller than the recommended file size in the Initial size (MB): field. 
 
Type in a number that is larger than the Initial size but smaller than the recommended file 
size in the Maximum size (MB): field. 
 
Click Set. 
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Select the C: drive. 
 
Click the No paging file radio button, and then click Set. 
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The “System Properties” warning message appears. 
 

 
 
Click Yes. 
 
Click OK to accept the new virtual memory settings. 
 

 
 
The “Performance Options” window re-appears, click OK. 
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Click OK. 
 
The “System Properties” message window appears.  
 

 
 
Click OK. 
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Step 6 
Navigate to and open the “Virtual Memory” window. 
 
What Drive or [Volume Label] contains the paging file? 
 
 
 
 

 
 
Reset the virtual memory back to the original settings. 
 
Select drive C: [Local Disk] > System managed size > Set. 
 
Next select drive E: > No paging file > Set. 
 
Add the check mark to Automatically manage paging file size for all drives, and then 
click OK. 
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The “System Properties” restart warning message appears. 
 
Click OK. 
 

 
 
Click OK to close the following windows: Performance Options, and System Properties. 
 
The “You must restart your computer to apply these changes” message appears, click 
Restart Now. 
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Step 7 
Click Start > All Programs > Games > right-click FreeCell > Send To > Desktop 
(create shortcut).  
 

 
 

Step 8 
Click and drag the shortcut FreeCell icon to the Start button.  
 
Do not release the shortcut icon. 
 

 
 
The “Start menu” appears. 
 
Drag the icon to All Programs. 
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The “All Programs” menu appears. 
 
Drag the icon to the bottom of the Startup folder. 
 
When a blue text Move to Startup appears next to the FreeCell shortcut icon, release 
the icon. 
 

 
 
You should see the FreeCell icon listed below Startup. 
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Step 9 
Log off Windows. 

 
Log on to Windows as an Administrator. 
 
What happens when you log in? 
 
 
 
Close the FreeCell application. 
 

 
 
Step 10 

Click Start > Search for programs and files > type run > Enter. 
 
Type regedit In the Open: field > OK > Yes. 
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CAUTION: Incorrect changes to the registry can cause system errors and/or system 
instability. 

 
The “Registry Editor” window appears. 
 

 
 
Expand the HKEY_CURRENT_USER Key. 
 
Expand the Software Key. 
 
Expand the Microsoft Key. 
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Expand the Windows Key. 
 
Expand the CurrentVersion Key. 
 
Select the RunOnce Key. 
 

 
 
Right-click anywhere in the white space on the right side of the window. 
 
Hover over New and select String Value. 
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Click anywhere in the white space of the window. 
 
Right-click New Value #1 > Rename. 
 
Type Solitaire and press Enter. 
 

 
 
Right-click Solitaire > Modify.  
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Type C:\Program Files\Microsoft Games\Solitaire\Solitaire.exe in the Value data field. 
 
Click OK. 
 

 
 
Close the “Registry Editor” window. 
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Step 11 
Log off Windows. 

 
Log on to Windows as an Administrator. 
 

 
 
What happens when you log in? 
 
 
 
Close all open Windows. 
 
Remove FreeCell game from Startup. 
 
Click Start > All Programs > Startup > right-click FreeCell > Delete > Yes. 
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Step 12 
Click Start > Control Panel > System and Security > Windows Update > Change 
settings. 
 

 
 
In the Important updates drop-down menu select Check for updates but let me choose 
whether to download and install them. 
 

 
 
Click OK > Continue. 
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Step 13 
Windows checks for updates. 
 
The “New updates are available” balloon appears. 
 
Double-click the shield icon in the system tray. 
 

 
 
Click the link that shows how many updates have been downloaded. Example: 50 
important updates are available. 
 

 
 
The “Select updates to install” window appears. 
 
Place a check mark next to the important and optional updates to be installed, and then 
click OK.  
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When the “Windows Update” window appears click Install updates. 
 

 
 
The “Downloading and installing updates…” balloon appears. 
 

 
 
You have successfully completed this part of the lab once the “Downloading and 
installing updates…” balloon appears. 
 
Reboot the computer. 
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Part 2: Windows 7 Hard Drive Maintenance 
 
In this part of the lab, you will examine the results after using Disk Check and Disk 
Defragmenter on a hard drive. 
 

Recommended Equipment 
• A computer running Windows 7 

 
Step 1 

Log on to Windows as an administrator. 
 
Start > Computer > double-click New Volume (G:). 
 
Right-click anywhere in the white space of the folder area for drive G: > Properties > 
Tools tab > Check Now. 
 
The “Check Disk New Volume (G:)” window appears. Make sure there is not a check 
mark in either checkbox then click Start. 
 

 
 
When the “Your device or disk was successfully scanned” screen appears, click the 
expand button next to See details. 
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How many stages were processed? 
 
 
 
Click Close. 
 
Select the Tools tab, click Check Now. Remove the check mark next to Automatically 
fix file system errors. Place a check mark in the checkbox next to Scan for and 
attempt recovery of bad sectors > Start. 
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When the “Your device or disk was successfully scanned” screen appears click the 
expand button next to See details. 
 

 
 
What stages were processed? 
 
 



IT Essentials: PC Hardware and Software v4.1                                     Chapter 12 – Lab/Student 
 

© 2007-2011, Cisco Systems, Inc. All rights reserved.  Page 27 

Click Close. 
 
Select the Tools tab, click Check Now. 
 
Place a check mark in both checkboxes then click Start. 
 

 
 
An information window opens. 
 

 
 
Why will Check Disk not start? 
 
 
 
 
Note: This message is displayed because a boot partition will be scanned, or a non-boot 
partition that is going to be scanned is open.  
 
Click Force a dismount. 
 
When the “Your device or disk was successfully scanned” screen appears click the 
expand button next to See details. 
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What stages were processed? 
 
 
 
What is being verified in each of the stages? 
 
 
 
 
Were any problems found with the volume? 
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If so what are they? 
 
 
 
Click Close and close all open windows. 
 

Step 2 
Start > Control Panel > System and Security > View event logs. In the left pane 
expand Windows Logs > select Application. 
 

 
 
Double-click the top event in the middle pane. If the displayed event is not Chkdsk, click 
the black down arrow until the Chsdsk event appears. 
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Which stages are shown as completed? 
 
 
 
Close all open windows. 
 

Step 3 
Start > Computer > right-click drive (C:) > Properties > select Tools tab > click 
Defragment Now button. 
 
The “Disk Defragmenter” window appears.  
 

 
 
Make sure drive C: is selected and then click Defragment disk. 
 
Windows starts defragmenting hard drive (C:). 
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What is the first process during defragmenting (See “Progress” column)?  
 
 
 
 
What are the three tasks performed for each Pass (See “Progress” column)? 
 
 
 
 
How many passes did it take to defragment drive C:? 
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When defragmenting is completed click Close. 
 
Close all windows. 
 
Note: It is not possible to view the detail of the defragmented hard drive through the GUI 
version of defragmenter. 
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Part 3: Managing Processes, and Regional and Language Settings in 
Windows 7 

 
In this part of the lab, you will examine regional and language settings, and explore how 
to manage processes in Task Manager. 
 

Recommended Equipment 
• A computer running Windows 7 

 
Step 1 

Log on to Windows as an administrator. 
 
Press keys Ctrl-Alt-Delete > click Start Task Manager > Processes tab.  
 

 
 
Click Show processes from all users. 
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Double-click the border around the tabs. 
 
Windows Task Manager is now in compact mode. 
 

 
 
Click Image Name. 
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Click Image Name again. 
 
What effect does this have on the columns? 
 
 
 

 
 
Click Memory (Private Working Set). 
 
What affect does this have on the columns? 
 
 
 
Double-click the outside border again to return to tabs mode. 
 

Step 2 
Open a browser.  
 
Note: Firefox is used in this lab. However, any browser will work. Just substitute your 
browser name whenever you see the word Firefox. 
 
Return to the Windows Task Manager. 
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Click Image Name so the list is in alphabetical order, then locate and select firefox.exe. 
 

 
 
Right-click firefox.exe > Set Priority. 
 
What is the default priority for the browser? 
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Set the priority to Above Normal. 
 

 
 
Click Change priority to the Windows Task Manager warning message. 
 

Step 3 
Click View > Select Columns. 
 

 
 
The “Select Process Page Columns” window appears. 
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Place a check mark next to Base Priority > click OK. 
 
Expand the width of the “Windows Task Manager” so the “Base Priority” column is visible. 
 

 
 
Click Base Pri. 
 
Which image name has a base priority of N/A? 
 
 
 
List the image name that has a base priority of Above Normal? 
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Step 4 
Reset Firefox.exe base priority to normal. Right-click firefox.exe > Set Priority > Normal 
> Change priority. 
 
Click View > Select Columns > uncheck Base Priority > OK. 
 

 
 
Close Firefox.  
 

 
 
Is Firefox listed as a process? 
 
 
Close all open windows. 
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Step 5 
Click Start > Control Panel > Clock, Language, and Region > Region and Language. 
 

 
 
The “Regional and Language” window appears. 
 

 
 
What regional format is being used? 
 
  
Click Additional settings. 
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What are the tabs that can be customized? 
 
 
Click Cancel. 
 
Click the drop-down menu in “Formats” area. Select Belarusian (Belarus). 
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Notice the changes to the output in the “Example” area of how data is displayed using 
this format. 
 
Click the drop-down menu in the “Format” area. 
 
Return the setting to the original format. 
 
Click Keyboards and Languages tab > Change keyboards. 
 

 
 
Click Add. 
 
Scroll down the list of options and expand Belarusian (Belarus) > Keyboard > select 
US > OK. 
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Click Apply to accept the changes. 
 

 
 
Close all opened windows 
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Step 6 
Right-click the Taskbar. 
 
Select Toolbars > Language bar to ensure that the Language bar is shown in the 
Taskbar. 
 

 
 
Right-click the Language bar in the Taskbar. 
 
Select Settings. 
 

 
 
The “Text Service and Input Languages” window appears. 
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What is the Default input language? 
 
 
 
Close all opened windows. 
 
 

Part 4: Managing Windows 7 System Performance 
 
In this part of the lab, you will manage and monitor Windows 7 system performance. 
 

Recommended Equipment 
• A computer running Windows 7 

 
Step 1 

Log on to Windows as an administrator. 
 
Note: Some antivirus or antispyware programs must be uninstalled on the computer for 
Windows Defender to work. 
 
To see if Windows Defender is turned off click Start > in Search programs and files type 
Defender > select Windows Defender.  
 
If the “This program is turned off” screen appears, click click here to turn it on. 
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Windows Defender should start, if not, uninstall any antivirus or antispyware programs 
and then click Start > in Search programs and files type Defender > select Windows 
Defender. 
 
Click Start > Control Panel > System and Security > Administrative Tools > 
Computer Management > expand Services and Applications > select Services. 
 
Close the Administrative Tools window. 
 
Resize and position both windows so they can be seen at the same time. 
 

 
 
Can Windows Defender check for updates? 
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Scroll the “Computer Management” window so you see the “Windows Defender” service. 
 
What is the Status of the service? 
 
 
 
Right-click Windows Defender service > select Stop. 
 

 
 
Note: The reason this service will be stopped is so you can easily see the results. When 
stopping a service, to free up system resources the service uses, it is important to 
understand how the overall system operation will be affected. 
 
The “Service Control” window appears and closes. 
 
Select the Windows Defender window so it is active. 
 

 
 
What must be done so Windows Defender can run? 
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Start the Windows Defender service, click Start now. 
 

 
 
Can Windows Defender check for updates? 
 
 
 
Close the Windows Defender window. 
 

Step 2 
Make sure the Computer Management window is open. 
 
Expand Event Viewer > Windows Logs > select System. 
 
Select the second event in the list. 
 

 
 
Look below the General tab then explain what has happened to the Windows Defender 
service. 
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Click the up arrow button on the keyboard or select the event above this one. 
 

 
 
Look below the General tab then explain what has happened to the Windows Defender 
service. 
 
 
 
Close all opened windows. 
 
 

Step 3 
Click Start > Control Panel > System and Security > Administrative Tools > 
Performance Monitor. 
 

 
 
Expand Data Collector Sets > right-click User Defined > New > Data Collector Set. 
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The “Create new Data Collector Set” window appears. 
 

 
 
In the Name field, type Memory Logs. Select the Create manually (Advanced) radio 
button > Next. 
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Select Performance counter > Next. 
 

 
 
Click Add. 
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From the list of available counters locate and expand Memory. Select Available MBytes 
> Add. 
 

 
 
Click OK. 
 

 
 
Set the Sample interval field to 4 seconds. Click Next. 
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Click Browse. 
 

 
 
Select drive (C:) > PerfLogs > OK. 
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The “Create new Data Collector Set” window appears. 
 

 
 
Click Next. 
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Click Finish. 
 

Step 4 
Expand User Defined > select Memory Logs > right-click Data Collector01 > 
Properties. 
 

 
 
The “DataCollector01 Properties” window appears. 
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Change the Log format: field to Comma Separated. 
 
Select the File tab. 
 

 
 
What is the full path name to the example file name? 
 
 
 
 
Click OK. 
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Step 5 
Select the Memory Logs icon in the left pane of the “Performance Monitor” window. 
 

 
 
Click the green arrow icon to start the data collection set. 
 
Notice a green arrow is placed on top of the Memory Logs icon. 
 

 
 

Step 6 
To force the computer to use some of the available memory, open and close a browser.  
 
Click the black box icon to stop the data collection set. 
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What change do you notice for the Memory Logs icon? 
 
 
 

 
 

Step 7 
Click Start > Computer > double-click drive C: > PerfLogs > Continue > VICKI-
PC_20101224-00001 > Continue. 
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Double-click DataCollector01.csv file. 
 
Note: If “Windows cannot open the file:” message appears select radio button Select a 
program from a list of installed programs > OK > Notepad > OK. 
 

 
 
What does the column farthest to the right show? 
 
 
 
 

Step 8 
Close the DataCollector01.csv file and the window with the PerfLogs folder. 
  
Select the Reliability and Performance Monitor window. Right-click Memory Logs > 
Delete > Yes. 
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Open drive C: > PerfLogs folder > right-click VICKI-PC_20101224-000001 > Delete > 
Yes. 
 
Close all open windows. 
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Part 5: Managing Windows 7 Remote Access 
 
In this part of the lab, you will remotely connect to a computer, examine device drivers, 
and provide remote assistance. 
 

Recommended Equipment 
• Two computers running Windows 7 that are directly connected to each other or through a 

switch or hub. 
• The two computers must be part of the same Workgroup and on the same subnet. 

 
 

Step 1 
Log on to Computer2 as a member of the administrator group. Ask your instructor for the 
user name and password. 
 
Click Start > Control Panel > System and Security > Allow remote access.  
 

 
 
In the “Remote Desktop” area, select the radio button next to Allow connections only 
from computers running Remote Desktop with Network Level Authentication (more 
secure). 
 
If a message appears warring the computer is set to go to sleep, click the Power 
Options link. 
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The “Select a power plan” screen appears. 
 

 
 
Click Change plan setting > select Never > select Never > Save changes. 
 

 
 
Click OK to close the warning message. 
 
In the “Remote Desktop” area, click the Select Users button. 
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Which user already has remote access? 
 
 
 
Since you will use this account to gain remote access, you do not need to add any users, 
click Cancel. 
 
Click Apply > OK to close “System Properties” window. 
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Click Start > Control Panel > System and Security > Windows Firewall > Turn 
Windows Firewall on or off.  
 

 
 
Make sure the Turn on Windows Firewall radio button is selected then click OK. 
 
Close all open windows, log off computer2, and move to Computer1. 
 

Step 2 
Log on to Computer1 as an administrator or a member of the administrator group. Ask 
your instructor for the user name and password. 
 
Click Start > All Programs > Accessories > Remote Desktop Connection.  
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When the “Remote Desktop Connection” window appears, type Computer2 in the 
Computer field and click Connect. 
 

 
 
In the “User name” field, type the account name you used to log on to Computer2. For 
example: John_Computer2.  
 
In the “Password” field, type the password for the user. 
 
Note: The user account must have a password. 
 

 
 
Click OK. 
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Click Yes to allow the connection. 
 
What happened to the desktop on Computer1? 
 
 
 

Step 3 
From Computer1, right-click the desktop of Computer2 > New > Folder. 
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Name the folder Remote Permission. 
 
Right-click the Remote Permission folder > Properties > Sharing > Advanced Sharing 
> Share this folder checkbox > keep the default name Remote Permission > OK. 
 
Click the Security tab. Make sure the user name from Computer1 is listed. If it is not, 
create and add the user name. Example: Click Edit > Add > type John_Computer1 > 
OK. 
 

 
 
Click OK > Close. 
 
Click Start > the arrow next to Log off > Disconnect. 
 

 
 

Step 4 
Log on to Computer2. 
 
Click Start > Control Panel > System and Security > Allow remote access 
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Notice “Remote Assistance” is activated by default. 
 
Click Advanced. 
 
The “Remote Assistance Settings” window appears. 
 

 
 
Make sure there is a check mark in the Allow this computer to be controlled remotely 
checkbox, set the invitation to 1 Hours, place a check mark in the Create invitations 
that can only be used from computers running Windows Vista or later checkbox, 
and then click OK. 
 
When the System Properties window appears, click Apply. 
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Step 5 
On Computer2, click Start > All Programs > Maintenance > Windows Remote 
Assistance. 
 

 
 
The “Do you want to ask for or offer help?” screen appears. 
 

 
 
Click Invite someone you trust to help you. 
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The “How do you want to invite your trusted helper?” screen appears. 
 

 
 
Which methods can you use to contact someone for assistance? 
 
 
 
Click the Save this invitation as a file. 
 
Locate the shared Remote Permission folder, and name the file Invitation to 
Computer1. 
 

 
 
What type of extension does the file have? 
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 Click Save. 
 

 
 
When the “Windows Remote Assistance” window appears, record the invitation 
password. 
 
Example: ZYK3XMW5HS7P 
 
Click Settings. 
 

 
 
Make sure there is a check mark next to Use ESC key to stop sharing control. 
 
Set the Bandwidth usage to Medium. 
 
Which features are disabled with a Medium bandwidth usage? 
 
 
 
 
Click OK. 
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Step 6 
On Computer1, click Start > Control Panel > Network and Internet > View network 
computers and devices > double-click Computer2. 
 
If you are asked to log on, use the user account from Computer1 
 

 
 
Double-click the folder Remote Permission. Double-click the file Invitation to 
Computer1. 
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When the “Remote Assistance” window appears, type in the password recorded in Step 
5. Example: ZYK3XMW5HS7P 
 

 
 
Click OK. 
 

Step 7 
From Computer2, answer Yes to allow access to the computer. 
 

 
 
Select the Windows Remote Assistance – Being helped by John_Computer1 window 
so it is activated. 
 

 
 
Click Chat. 
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In the chat field type Hi John_ Computer1, my optical drive will not work. Click Send. 
 

Step 8 
From Computer1, click the Request control button in “Windows Remote Assistance” 
main menu. 
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Step 9 
From Computer2, click the Allow John_Computer1 to respond to User Account 
Control prompts checkbox. Click Yes. 
 

 
 

Step 10 
From Computer1, select System Properties window for Computer2. 
 

 
 
Note: If the Computer2 System Properties window is closed, you need to open it before 
you continue.  
 
Click Hardware tab > Device Manager. 
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Right-click the optical drive that has a black down arrow. Select Enable. 
 

 
 
Click the Stop Sharing button in Windows Remote Assistance main menu. 
 
Click the red X button to close the Windows Remote Assistance connection. 
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Close all open windows and log off Computer1. 
 

Step 11 
On Computer2, click on Device Manager so it is activated. 
 

 
 
Dose the optical drive have a black arrow? 
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Close the Device Manager window and the Windows Remote Assistance window. 
 
Delete the Remote Permission folder and empty the Recycle Bin.  
 
Select the System Properties window.  
 
Select the Remote tab and place a check mark next to Don’t allow connection to this 
computer > OK. 
 

 
 
Log off Computer2. 
 


